(401) Unauthorized.:SmilingGoat.Syndication

Topics: Developer Forum, Project Management Forum, User Forum
Apr 12, 2007 at 5:42 PM
Hello,

I am a bit new to Sharepoint, and I am having difficulty using this Web-part with an RSS feed I created. The feed is legal; I checked the RSS 2.0 spec. I believe the problem is that the feed is internal. It is a feed on our intranet. Here is the error message I get when I put the url in the FeedReader webpart:

"our internal url does not appear to be a valid RSS feed. If the feed is valid, please ensure your proxy server settings are correct if you use a proxy server.
Error returned from FeedReader: The remote server returned an error: (401) Unauthorized.:SmilingGoat.Syndication"

Can FeedReader use feeds that are not accessible to the outside world? If so, what do I need to do to fix this?

Thanks in advance

Tim
Coordinator
Apr 12, 2007 at 11:32 PM
Tim,

the FeedReader cannot access authentication-required feeds.
Apr 16, 2007 at 6:12 PM
Hi Tim,

Please pardon my ignorance. Is that because the feed is located on our intranet, even if the sharepoint site is also located within our private network?

Thanks again,

Tim
Coordinator
Apr 16, 2007 at 9:03 PM
That's right -- FeedReader doesn't accept any feed that requires authentication...the web part also does not pass authentication on to internal feeds (because of the windows double-hop issue) as it is actually the server sharepoint process requesting the feed.


tmcgilvreay wrote:
Hi Tim,

Please pardon my ignorance. Is that because the feed is located on our intranet, even if the sharepoint site is also located within our private network?

Thanks again,

Tim

Nov 15, 2007 at 10:25 AM
Tim -

I wanted to use FeedReader to aggregate 'My Site' blogs from the same WSS instance on our Intranet. i.e. FeedReader will be on the WSS home page showing the latest blogs.

Since the blog feeds will use the same security as our intranet (as will need authentication), are you saying that I can't use FeedReader at all for this scenario?

thanks,

Steve
Feb 18, 2008 at 12:50 AM
I encountered this same issue.

Tim's explanation (that the web part does not pass through authentication for internal feeds "due to the windows double-hop issue") should not apply to us - we are using Kerberos, which should avoid double-hop issues. Yet it still does not allow the usage of feeds from other internal Sharepoint sites.

The out-of-the-box RSS feed web part does not work either I might add.

I did find something interesting though - if I replace the hostname of my Sharepoint server with "localhost", this web part will get the feed from Sharepoint. That is, if the feed is from http://myportal/blah-blah-blah (where myportal is the hostname of the MOSS server), if I change the feed URL to http://localhost/blah-blah-blah, it does read it without any errors!

The problem is that clicking on the articles then takes you to an unkown URL, since "localhost" is encoded in the links, and it will be interpreted by the client PC as a URL (where setting it as a web part property, it is interpreted by MOSS).

In my case, I made a quick little change to replace localhost in any link with the hostname of the MOSS server and then it all works, although I still cannot understand exactly why....
Apr 9, 2008 at 6:09 PM
We have had a similar error where we have multiple feed URLs separated by semicolons.

We are using SharePoint.

Initially, all the feeds work. However, later we will get an error message from the first and sometimes the second RSS feeds.
The others display fine. I have changed the order of the URLs and the problem seems to track along with the position of the URL and has little to do with the URL itself.

If I "edit" the URL list (without actually changing it) and save the "changes", the feed comes up and displays properly for a while.

This problem continues regardless of where the RSS feeds are coming from.

The problem seems to track along with whatever RSS feed window is uppermost on the SharePoint page and affects the first and sometimes second RSS feeds in the list.

Tim: Can you help?

Thanks,

John
Apr 17, 2008 at 3:58 PM
Edited Apr 17, 2008 at 3:58 PM
We are successfully using the Smiling Goat webpart in our WSS 3.0 environment.

One user has a site with multiple subsites (more than 20 subsites). We use the Smiling Goat webpart on each of the subsites to display a link to a particular document on each subsite onto the main sites homepage.

In order to get the feed to work, you click on the heading of the Goat webpart that you are trying to get the hash code for, go to Actions -> View RSS feed. It will open the feed for that webpart, copy the address (that includes the hash portion) out of your Address bar. Go back to the site where the feed is to be displayed, open the Goat webpart on THAT site, and add the URL from the originating site that we copied. Make sure to put a semicolon after the new address that you added. Save. All done.

Apr 29, 2008 at 3:04 PM
Another workaround that seems to have fixed the "(401) Unauthorized.:SmilingGoat.Syndication" bug by adding an RSS feed web part at the top of the page and hiding it. This gets the initial 401 error out of the way (and since it is hidden does not display) and permits subsequent RSS web parts to display just fine.

- John
Jul 17, 2008 at 5:50 PM
Edited Jul 17, 2008 at 5:50 PM
we had the same goal, to access feeds that were data-driven, thus required access to a sqlserver (i.e. windows authentication).

i have added a patch that is currently pending review.  please see the note i attached to the patch.

in a nutshell, i have a feed page (aspx) which reads from sqlserver in order to create the rss xml.  the sharepoint server, iis server for the feed aspx, and the sqlserver are all separate physical servers, and everything works fine now with the patch, using windows authentication/kerberos.
Coordinator
Jul 17, 2008 at 6:39 PM


zuckerbraun wrote:
we had the same goal, to access feeds that were data-driven, thus required access to a sqlserver (i.e. windows authentication).

i have added a patch that is currently pending review.  please see the note i attached to the patch.

in a nutshell, i have a feed page (aspx) which reads from sqlserver in order to create the rss xml.  the sharepoint server, iis server for the feed aspx, and the sqlserver are all separate physical servers, and everything works fine now with the patch, using windows authentication/kerberos.


Thanks for the patch submit.  The syndication library executes on the server, using the credentials of the worker process for sharepoint, not the end user's credentials.  so this would only work in those instances.  people expecting authenticated feeds using user credentials would still fail (unless they were using kerberos in their entire network).
Sep 10, 2010 at 10:50 PM

This has happened to us after every build of a new SharePoint server.  The fix is to disableLoopbackCheck:

This is straight from Microsofts website:  KB896861

Set the DisableLoopbackCheck registry key, follow these steps:

  1. click start, click run, type regedit, and then click OK.
  2. In the registry editor, locate and then click the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
  3. Right-Click Lsa, point to New, and then click DWORD value.
  4. Type DisableLoopbackCheck, and then click Modify.
  5. In the Value data box, type 1, and then click OK.
  6. Quit Registry Editor and then restart your computer.