Error on MOSS 2007 Beta TR2

Topics: User Forum
Sep 25, 2006 at 9:20 PM
Hi,

I installed FeedReader on a Sharepoint Portal Server 2007 Beta (technical refresh 2) and get the following error within the webpart content area after adding the web part to a page:

"An unexpected error occurred: Object reference not set to an instance of an object."

Any help with this problem would be very much appreciated.

Thanks in advance,

Tom Marschner
Coordinator
Sep 29, 2006 at 7:33 PM
was it installed to the GAC?
Dec 3, 2006 at 6:38 AM
I've installed it from the available .cab file and i've checked the GAC if the dll are registered. Both the dlls are there but i too get the same error message... does anyone have any idea how to solve this problem?
Coordinator
Dec 4, 2006 at 11:45 PM
hi all, i'm working to reproduce and will try to report back.
Coordinator
Dec 4, 2006 at 11:46 PM
can you check your event logs and see if there is anything specific? do you have .net 1.1 installed on those machines as well?
Dec 5, 2006 at 6:31 AM
There's nothing specific I found in the event and I've .net 1.1 installed in the machine
Jun 19, 2007 at 12:50 PM
I am facing the same exception as well - did anyone find a fix to this ?
Jun 19, 2007 at 8:24 PM
Edited Jul 6, 2007 at 3:57 PM
The error is on line 225 in RssWebPart.cs

outputString = this.PartCacheRead(Storage.Shared, "FeedReader" + this.Parent.ClientID).ToString();

<Edit>
Actually it looks like the error happens far before that. In my case my request.GetResponse() (line 175 in RssFeed.cs) was failing because my proxy server requires authentication. Adding a line request.Proxy.Credentials = new NetworkCredential( "uesrname", "password", "domain" ) resolved that problem.
Jun 21, 2007 at 3:33 PM
I've been using this webpart for 8 months now, but in the last couple of days, I've started getting this error message (An unexpected error occurred: Object reference not set to an instance of an object). Sometimes, hitting refresh on the browser clears it up, other times, it doesn't. Any ideas on where to start? (Using WSS 2.0)
Jun 21, 2007 at 3:54 PM
Hi,

I am also having this problem. I'd love to use the advice given here but: (101 questions coming up - sorry...)

What is the GAC?
Which event logs should I check? Where?
How do I know if .net 1.1 is installed?

Thanks in advance

Sunny


Jul 9, 2007 at 7:57 AM
i am also getting this exception, as chandlerchao suggests:
The error is on line 225 in RssWebPart.cs

outputString = this.PartCacheRead(Storage.Shared, "FeedReader" + this.Parent.ClientID).ToString();

i found this.PartCacheRead(...) returns null, and exception throws, that's probably due to the RssFeedReader constructor is not called when RenderWebPart(...) called, thus the cache is still null, any idea?
Aug 3, 2007 at 12:09 PM
Edited Aug 3, 2007 at 12:29 PM
Hi,

I installed FeedReader on a Sharepoint services 2003 (technical refresh 2) and get the following error within the webpart content area after adding the web part to a page:

"An unexpected error occurred: Object reference not set to an instance of an object."

but after few few days i fixed this problem. To fix this problem just give public IP address to the server which is running sharepoint services 3.0, and remove proxy setings in the RSS FeedReader webpart.

Feb 18, 2008 at 6:18 PM
Edited Feb 18, 2008 at 6:18 PM
I am stuck at the same problem. But I receive the error just at a wiki site. On a regular webpart page or blog it works fine.
Any solution?